Błąd
  • Błąd podczas ładowania danych z kanału informacyjnego
StartPowiadomieniaJoomla 1.0.15 - wydania polskie

Joomla 1.0.15 - wydania polskie polecany

Oceń ten artykuł
(0 głosów)

Wydania stabilne i bezpieczneTrzy najnowsze polskie wersje Joomla! 1.0.15 udostępniliśmy w naszej plikowni. Wszystkie trzy wydania zawierają: pakiet języka polskiego strony frontowej, polską wersję instalatora, przykładowe dane w języku polskim. W wydaniach nieoficjalnych - JAL oraz JIE - spolonizowane zostało również zaplecze administracyjne. Pobierz:
Joomla! 1.0.15 PL :: wydanie oficjalne
Joomla! International Edition 1.0.15
Joomla! + Admin Language 1.0.15

Dlaczego trzy wersje?

W oryginalnym Joomla! - bez zmian w kodzie - można spolonizować jedynie stronę frontową. Zaplecze administracyjne wyświetlane jest tylko w języku angielskim. Problem lokalizacji zaplecza zostal rozwiązany w wydaniach rozszerzonych - zmodyfikowanych i nieoficjalnych:

  • projekcie Joomla! + Admin Language, udostępnianym przez PCJ! od wydania Joomla 1.0.3,
  • projekcie Joomla! International Edition, udostępnianym przez PCJ! od wydania Joomla 1.0.13.

Którą wersję wybrać?

Nowi użytkownicy Joomla! często zadają pytanie, które z wydań zainstalować. Prostej odpowiedzi nie ma.

Jeśli angielski język etykiet i komunikatów zaplecza nie będzie przeszkodą dla administratorów, to najlepiej wybrać wydanie oficjalne. Nie ma zbytniego znaczenia, czy będzie to wydanie polskie, czy oficjalne. Zawsze bowiem można doinstalować pakiet języka polskiego obsługujący stronę frontową. A najlepiej dlatego, że aktualizacji do nowej wersji można dokonać natychmiast po jej opublikowaniu.

Aby dysponować zapleczm w języku polskim, trzeba zainstalować wybrane wydanie zmodyfikowane JAL lub JIE.

Powrót Joomla! + Admin Language

Publikując JIE 1.0.13-iso (zob. Joomla! w kapeluszu), ogłosiliśmy, że projekt J!+AL zakończył swój żywot. Okazało się jednak, że trzeba od tego zamiaru odstąpić. O ile pakiet JIE-utf sprawdził się wyśmienicie, zwłaszcza w nowych instalacjach i wszędzie tam, gdzie baza danych jest kodowana w utf-8, to pakiet JIE-iso powodował różne problemy, czasem zupełnie niepotrzebnie - można ich było zaoszczędzić.

Przygotowując wydanie J!+AL 1.0.15 wykorzystaliśmy doświadczenia z obu projektów, wcześniejszego Joomla 1.0.x+Admin-pl oraz J!IE.

Wydanie J!+AL 1.0.15, podobnie jak wydanie oficjalne, kodowane jest w ISO. Przeznaczone jest zarówno do aktualizacji starszych wersji Joomla!, kodowanych w ISO, jak i do nowych instalacji. Instalator J!+AL nie wpływa w żaden sposób na kodowanie bazy danych, a więc zachowuje się tak samo, jak instalator w wydaniu oficjalnym (choć jest spolonizowany i nieco rozszerzony).

J!+AL jest również dobrym rozwiązaniem w przypadku witryn dwujęzycznych, jeśli jeden z języków jest kodowany w ISO 8859-1 (jak j. angielski). Jeśli chcemy wydawać witrynę wielojęzyczną, zalecanym rozwiązaniem jest Joomla! International Edition.

Joomla! International Edition

J!IE, zainicjowane przez Adriana Mummeya jest optymalnym rozwiązaniem dla witryn międzynarodowych i wielojęzycznych ze względu na zgodność ze standardem kodowania w UTF-8. Podkreślmy wszakże, że mamy tu doczynienia z taką zgodnością z UTF-8, jaka jest możliwa w przypadku Joomla 1.0.x, który - jak wiadomo - nie jest w pełni dostosowany do kodowania utf-8. Mogą się zatem zdarzyć pewne niespodziewane problemy z kodowaniem, np. niektórych znaków specjalnych.

Wydanie J!IE 1.0.15, które udostępniamy, zostało w całości przygotowane przez Polskie Centrum Joomla! (podobnie zresztą, jak poprzednie 1.0.13)

J!IE 1.0.15 wymaga serwera z MySQL w wersji od 4.1 wzwyż, a więc obsługującego kodowanie UTF-8.

Co nowego?

Przede wszystkim są to wydania uwzględniające poprawki wniesione do oficjalnych wydań Joomla 1.0.14 i Joomla 1.0.15 (szczegóły - dalej). Ponadto we wszystkich trzech wydaniach:

  • poprawiono skrypty i pliki językowe instalatora,
  • wprowadzono różne poprawki w plikach językowych, w tym ujednolicające tłumaczenie do reguł przyjętych w J! 1.5
  • w niektórych skryptach strony frontowej zastąpiono stałymi angielskie etykiety i komunikaty językowe
  • zamieszczono dodatkowy szablon strony frontowej rhuk_milkyway_10 (adaptacja z 1.5),

Najistotniejszą zmianą językową jest zastąpienie nazwy blog terminem przegląd. Zamiast bloga artykułów z kategorii czy bloga artykułów z sekcji mamy przeglądy artykułów…. Przywróciliśmy również wycofaną chwilowo nazwę dodatki. Zamiast Sond mamy Ankiety, zamiast Katalogu www [Weblinks], mamy Zasoby, zamiast Banerów mamy Reklamy. Zmiany te spowodują pewne zamieszanie, ale uznaliśmy za konieczne dostosowanie terminologii do nazewnictwa zastosowanego w Joomla 1.5 ze względu na system pomocy.

Znane problemy

Dotychczas spotkaliśmy trzy:

  • nie działa przycisk Zarejestruj w formularzu rejestracyjnym,
  • na zapleczu nie wyświetlają się wszystkie porady (dymki),
  • wpinacz Pomocy nie wyświetla całych artykułów,

Dwie pierwsze usterki zostały już naprawione. Przyczyną były… podwójne spacje w plikach językowych i plikach .xml. Osoby, które pobrały pakiety instalacyjne w pierwszych 3-4 dniach ich publikacji, a natkną się na ten problem, prosimy o pobranie i zainstalowanie odpowiedniej łatki aktualizującej, naprawiającej usterki.

Trzeciego błędu nie udało się zdiagnozować. Aby wyświetlać całe artykuły, trzeba wcześniej skorzystać z odnośnika Dziennik zmian. Dziwne, ale po jego wywołaniu reszta działa poprawnie.

Zwiększone bezpieczeństwo

We wszystkich trzech wydaniach uwzględniono poprawki wniesione do oficjalnych wydań Joomla 1.0.14 i Joomla 1.0.15. Są to głównie poprawki czyniące witryny bezpieczniejszymi:

  • SECURITY [DUŻY] Usunięto podatność na zdalne włączenie pliku.
  • SECURITY [MAŁY] Usunięto zagrożenie atakiem XSS w komponencie Szukaj.
  • SECURITY [MAŁY] Usunięto zagrożenie atakiem XSS w wynikach przeszukiwania strony.
  • SECURITY [MAŁY] Wyłączono możliwość korzystania ze znaku uniwersalnego w filtrze Szukaj.
  • SECURITY [MAŁY] W komponencie zaplecza Content naprawiono liczne usterki powodujące nieefektywne sprawdzanie liczb całkowitych.
  • SECURITY [MAŁY] Naprawiono problem w rozróżnianiu wielkości liter w polu Filter.
  • SECURITY [DUŻY] W komponentach zaplecza administracyjnego usunięto zagrożenia atakiem CSRF.

Znaczenie wprowadzonych zmian jest dla bezpieczeństwa witryn niebagatelne. Kto jeszcze - oczekując na wydania polskie - nie zaktualizował swoich starszych wersji Joomla!, winien to uczynić jak najszybciej (pamiętając o kopii bezpieczeństwa!).

Poza poprawkami wymienionymi powyżej wprowadzono inne, pomniejsze zmiany:

  • Usunięto problem wylogowania z zaplecza administracyjnego
  • Naprawiono błąd komponentu Szukaj - niewłaściwe filtrowanie krótkich słów
  • Poprawiono wydajność wyrażeń regularnych w komponencie Szukaj (zmniejsza obciążenie zasobów CPU podczas przeszukiwania)
  • Dodano przycisk Podgląd (witryny) w głównym oknie zaplecza administracyjnego
  • Naprawiono błąd w odnośnikach paginacji (usunięto niepotrzebną spację w odnośnikach)
  • Różne drobne poprawki API
  • W znacznej części skryptów uaktualniono oznaczenie licencji GNU GPL

Instalacja

Instalacja każdego z tych wydań przebiega w standardowy, opisywany już wielokrotnie sposób:

  1. Pobierz wybrany pakiet
  2. Rozpakuj pakiet instalacyjny.
  3. Prześlij pliki na serwer do katalogu instalacyjnego.
  4. Wywołaj w przeglądarce adres witryny.
  5. Wybierz język instalacji.
  6. Wykonaj polecenia instalatora.
  7. Przed uruchomieniem witryny usuń katalog instalacyjny.

Aktualizacja poprzednich wersji

Poprzednie wersje Joomla! - po uprzednim sporządzeniu kopii zapasowej witryny - można zaktualizować na dwa sposoby:

  • dowolne wydanie - nadpisać plikami pakietu instalacyjnego pliki w katalogu Joomla!
  • wydanie 1.0.13 - nadpisać pliki w katalogu Joomla! plikami łatki aktualizującej.
Ostatnio zmieniany Śr. 28 Mar 2012
comments powered by Disqus Powrót na górę

Aktualności - spis treści

Kalendarz publikacji

2018
2017
2016
2015
2014
2013
2012
2011
2010
2009
2008
2007
2006
2005
Oglądasz teraz:   StartPowiadomieniaJoomla 1.0.15 - wydania polskie

WCAG 2.0 dla Joomla!

Twoje konto